WiFi issues in Barnes accommodation Friday 16th April 2021 08:00:00


We are investigating the cause of a WiFi outage which occurred unexpectedly last night in Barnes accommodation.

Some students are still experiencing issues accessing eduroam this morning, and one of our technicians is currently on site working to resolve the issue.

We apologise for any inconvenience this is causing to our students.

Update 09:09 - We believe this issue is now resolved. If you have any further issues please report them to the IT Service Desk.

Update 08:30 - This outage may also be affecting Keele Day Nursery and the Accommodation Office at Barnes.