Microsoft Teams Tuesday 27th April 2021 12:28:17


Microsoft are aware of issues accessing Microsoft Teams & Audio/Video calls. Users able to access Microsoft Teams may experience degraded performance with multiple features.

We'll update on the situation shortly.

Update 13:27 - Microsoft have reported that they have completed work to resolve these issues and users should now start seeing a return of service.

Update 13:05 - Microsoft have confirmed these issues are affecting users globally and they are working to resolve the issues. Keele users are having intermittent issues with accessing calls, using chat/comments, and with call quality.