Turnitin unavailable Tuesday 8th June 2021 11:41:00


Turnitin is currently unavailable - the supplier are working to resolve the issues with the system. Apologies for any inconvenience this is causing for our users.

Update 12:57 - Keele users are seeing a return to service

Update 12:25 - Turnitin have confirmed that users will see a return to service shortly.

Update 12:04 - It's believed this issue is as a result of issues with the content distribution network, fastly, which has also caused outages on major websites including gov.uk.

Fastly has reported it has applied a fix which should mean a return to service shortly.