Turnitin performance issues 06/04/2022 Wednesday 6th April 2022 09:00:00


Turnitin have reported an ongoing issue regarding an error message users may see when marking assignments using the tool.

Turnitin have said: Users of Turnitin and Turnitin UK may still be intermittently receiving the “Pool "ev-app-yang-POOL" is down” error when viewing submissions. Users of these services may also experience intermittent slowness and/or freezing when applying QuickMarks or commenting on a submission.

In order to restore full service functionality, we will be undertaking an emergency maintenance on April 6th. It is expected to last for 1 hour at 11am on Wednesday 6th April.

Update 13.48: Turnitin have now confirmed the system should be back up and running.

Update 12:40: Turnitin have confirmed the emergency maintenance is overrunning. Apologies for any inconvenience this is causing for our colleagues

Updates from Turnitin will be posted on their status page - https://turnitin.statuspage.io/incidents/7pw0h0rsfygv